Apply does not work with API key

hello,

i’m using cursor with my own api key. however when i try to apply gpt updates i get the following message:
CleanShot 2024-02-25 at 20.13.08

is there a way to make it work?

thank you

Hello! The Apply button does not work through OpenAIs normal chat API, so unfortunately we cannot bill your API key.

imo - this feature is totally worth the subscription, and is what convinced me to switch from using API Key “at cost” to being an enterprise subscriber.