Copilot++ not working: Error in streaming cpp [internal] Protocol error

I’m testing Cursor on my work computer. Everything works except Copilot++. When I edit a line I can see the following logs

I’m on a MacBook Pro which uses a security software called Zscaler. I didn’t find any rejected requests in the Zscaler logs so I’m not sure if this is the problem or not.

Does anyone have experience with this or any idea on how to get more information about the failing requests?

1 Like

Hmm, this might have been a temporary error on Cursor’s side. Does Copilot++ still not work for you?

Unfortunately it still doesn’t work. I tested it on my private machine and there are no problems. Both are similar MacBooks but on the company machine I have Zscaler. So I’m assuming that’s the problem. Could be anything else though. So it would be great to understand how to further debug this problem

Have the same issue - Copilot++ does not work behind Zscaler (proxy/firewall).

Often such issue pops up re: Zscaler root CA certificate needs to be added / accounted for in application specific trust stores.

@almirm thanks for confirming the issue. I remember having a problem with GitHub Copilot a while ago. That was also related to certificates. Installing an extension (win-ca or mac-ca) worked back then. Will try and see if they help here as well. Here are some additional infos:

GitHub Copilot behind a Proxy with a self-signed certificate chain does still not work · community · Discussion #35544
self signed certificate in certificate chain on github copilot

1 Like

@jkettmann yes - had to do the same fix with GitHub Copilot that you explained - installing mac-ca into node environment used by vscode. This fix also works for using GitHub Copilot in Cursor (due to being a fork of vscode).

Unfortunately this fix does not work for Copilot++ which seems to be using C++ (cpp) implementation of some communication protocol (assume streaming data back and forth) - based on your posted screenshot above.

Codebase indexing which is suppose to be “local”, doesn’t work because I am also behind a zscaler proxy. Been able to fix it various places, but can’t figure it out for Cursor.

yeah i am getting the same error as well. But Github Copilot works for me not Copilot++

Anything we can do to bring it to the Cursor dev team attention?

We are aware of a small amount of downtime. Working to bring this to near 0.

1 Like

This has nothing to do with downtime. The indexer doesn’t work because it doesn’t use the system certificate chains, which in my case is managed by Zscaler.

1 Like

Same with me - not related to downtime. Copilot++ and index stop working and get error messages posted in this thread when turn on Zscaler. Issue as described by @tnypxl.

@sualeh How are these custom C++ streaming processes referencing system certs? Can this be overridden with a cursor-specific environment variable? Something like, “CURSOR_CA_BUNDLE=/path/to/cert.pem”?