Editor stopped giving suggestions

It said at one time that I used my credits or something.

Upon hovering on copilot++ it says - requires pro(custom model)
But on the website it says - i have plenty requests left.

Also I added now Antropic API key and enable only Antropic model. Despite this I get no suggestions! only the suggestion to open chat or generate.
I want back the multiline siggestion with tab autocomplete.

On your website it says

OpenAI Key

If you’d prefer not to upgrade, you can enter your OpenAI key to use Cursor at-cost. To start, hit the gear in the top-right of the editor.

Meaning I don’t need to be pro

1 Like

Copilot++ requires pro since it is a cursor specific model.
(Our internal model is so much better than what we can achieve publically for a copilot so it requires a subscription.)

You can use the anthropic models with your api key!

I am confiused!

Copilot++ was enabled from the beginning and it worked, now it does not despite the fact that i have requests.

Now I disabled copilot++ and still get no suggestions , despite the fact that i have added antropic api key and enabled their models.
So what is the point to add api key and models if they nobody to use them?

I thought antropic models play together with copilot++ - the multiline completion…

In short, can i get multiline autocompletion with aantropic models, or is with copilot++ ?
I have to pay pro for the multiline suggestions?
But then there is no point to add antropic api because the model is copilot++?
I am utterly confused!

Your Copilot++ limit is not determined by any usage numbers on the dashboard. If you have a Pro subscription, you get unlimited Copilot++ suggestions; otherwise, there’s a cap.

Copilot++ only functions with Cursor’s own requests, not with your own API key.

Your API key will work for other features like Chat or Inline Generation.

Hi all,

So if I understand well, completion or suggestions are only a feature of Copilot++?