How can I disable the visibility of AI Pane / Secondary Side Bar completely?

I used the “workbench.action.moveSecondarySideBarToPanel” command to move the AI Chat window to the Panel. However, when I click the “New Chat” (+) button , it toggles the AI Pane / Secondary Side Bar visibility that displays a placeholder text “Drag a view here to display”.

How can I fully disable the AI Pane / Secondary Side Bar visibility to prevent it from opening, considering there is no content to show once the AI Chat is in the Panel?

Hi @romeromarcelo,

You can toggle the AI Pane by clicking the x button (given screenshot below). You can also toggle the visibility of the pane by doing cmd/ctrl+L.

Please let me know if it doesn’t work!

Hey @shaoruu, thanks for your reply!

But what I actually want is to use AI Chat directly on the Panel without the AI Pane/Secondary Sidebar opening every time I start a new chat. In other words, I don’t want to manually close it by clicking the “x” or using keybindings each time I start a new chat.

CleanShot 2024-04-09 at 2 .59.44

Hi @romeromarcelo,

This is very weird, the expected behavior is to use AI Chat inside the AI pane, not sure why it is opening a complete different pane for you :thinking:

Which version of Cursor are you on? And, by any chance, do you have any custom settings with the AI pane / side bars?

Sorry for this to happen!

Same is happening for me!! This is SO anoying!!!

Version: 0.31.3
VSCode Version: 1.86.2
Commit: fcd6e551d6f014d13071eac9bd4904e7e0346720
Date: 2024-04-02T20:20:11.019Z
Electron: 27.2.3
ElectronBuildId: undefined
Chromium: 118.0.5993.159
Node.js: 18.17.1
V8: 11.8.172.18-electron.0
OS: Darwin arm64 21.6.0