Indexing only reads first folder in the workspace

Trying to use indexing on a workspace with multiple folders, but it only indexes the codebase in the first folder and skips all the other folders in the workspace. Is this a known issue or a lacking feature? If not, what are the best steps to debug and resolve?

Deleting and resyncing index hasn’t helped.

1 Like

Yea, codebase indexing only uses the first open folder in the workspace. As a workaround, you could try putting both folders into one parent folder and open that parent folder in Cursor.

Not sure if anyone thinks this would be worth a new feature, but I’d definitely like to have an option to index additional folders in the workspace.