Well, badly need for a Linux Arm64 Version!

I’m here because I’m exhausted. Firstly, great appreciation for the developer team and this brilliant software, as this is the ONLY working AI-driven IDE so far.
However, while it works well on my mac, now, on my another arm64-based ubuntu os, it doesn’t. I just cannot find the arm64 download button on that page.
So it cost me great time to figure it out about how to run that amd64 AppImage, at least, to run. Box64, QEMU, Docker, none of them worked. Looks like it’s the end for my entire day of exploring the methods of running an amd64 app natively or virtually on an arm64 machine.
You know that many Linux machine, like Raspberry Pi and many other embedded systems, build on arm. Also, most Linux softwares offer an arm64 version, including vscode ( I guess cursor is a fork of that). It’s really an urgent thing and important consideration of taking an Linux arm64 version into account!

1 Like